CVE-2015-6524 — activemq-broker
Fix: apache/activemq@22f2f3dCVE-2015-6524 is a CWE-255 vulnerability in org.apache.activemq:activemq-broker. A fix is available for org.apache.activemq:activemq-broker — see the affected versions and patch details below.
Improper Input Validation in Apache ActiveMQ
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.activemq:activemq-broker☕org.apache.activemq:activemq-jaasReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:activemq-broker | ≥ 5.0.0&&< 5.10.2 | 5.10.2org.apache.activemq:activemq-broker:5.10.2 |
| ☕Maven | org.apache.activemq:activemq-jaas | ≥ 5.0.0&&< 5.10.2 | 5.10.2org.apache.activemq:activemq-jaas:5.10.2 |
Affected Products
activemqapachefedorafedoraprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:activemq-broker to 5.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-6524 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2015-6524 in your dependencies?
Find it across Maven, including transitive dependencies.