CVE-2026-28343 — @ckeditor/ckeditor5-html-…
MEDIUMCVE-2026-28343 is a medium-severity (CVSS 6.4) Cross-site Scripting (XSS) vulnerability in @ckeditor/ckeditor5-html-support. A fix is available for @ckeditor/ckeditor5-html-support — see the affected versions and patch details below.
CKEditor: Cross-site scripting (XSS) in the HTML Support package
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-28343.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@ckeditor/ckeditor5-html-supportnpmckeditor5npmDescription
Impact
A Cross-Site Scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration.
This vulnerability affects only installations where the editor configuration meets the following criteria:
- General HTML Support is enabled,
- General HTML Support configuration allows inserting unsafe markup (see Security section to learn more).
Patches
The problem has been recognized and patched. The fix will be available in version 47.6.0 (and above).
Workarounds
CKEditor 5 recommends configuring General HTML Support securely to ensure that unsafe content is not accepted. Please refer to the Security section for detailed guidance.
Credits
CKEditor 5 would like to thank:
- Emilio Kevin
- Jeongwoo Lee, Younsoung Kim, Minseok Kim and Jinyeong Kim from ENKI Whitehat
for responsibly reporting this vulnerability.
For more information
Email us at [email protected] if you have any questions or comments about this advisory.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @ckeditor/ckeditor5-html-support | ≥ 29.0.0&&< 47.6.0 | 47.6.0npm install @ckeditor/ckeditor5-html-support@47.6.0 |
| 📦npm | ckeditor5 | ≥ 29.0.0&&< 47.6.0 | 47.6.0npm install ckeditor5@47.6.0 |
Affected Products
ckeditor5ckeditorDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @ckeditor/ckeditor5-html-support, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @ckeditor/ckeditor5-html-support to 47.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-28343 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2026-28343 in your dependencies?
Find it across npm, including transitive dependencies.