CVE-2024-45613 — ckeditor5
CVE-2024-45613 is a Cross-site Scripting (XSS) vulnerability in ckeditor5. A fix is available for ckeditor5 — see the affected versions and patch details below.
CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45613.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
ckeditor5npm@ckeditor/ckeditor5-clipboardnpmDescription
Impact
During a recent internal audit, we identified a Cross-Site Scripting (XSS) vulnerability in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration.
This vulnerability affects only installations where the editor configuration meets the following criteria:
- The Block Toolbar plugin is enabled.
- One of the following plugins is also enabled:
- General HTML Support with a configuration that permits unsafe markup.
- HTML Embed.
Patches
The problem has been recognized and patched. The fix will be available in version 43.1.1 (and above), and explicitly in version 41.3.2.
Workarounds
It's highly recommended to update to the version 43.1.1 or higher. However, if the update is not an option, we recommend disabling the block toolbar plugin.
For more information
Email us at [email protected] if you have any questions or comments about this advisory.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | ckeditor5 | ≥ 40.0.0&&< 43.1.1 | 43.1.1npm install ckeditor5@43.1.1 |
| 📦npm | @ckeditor/ckeditor5-clipboard | ≥ 40.0.0&&< 43.1.1 | 43.1.1npm install @ckeditor/ckeditor5-clipboard@43.1.1 |
Affected Products
ckeditor5ckeditorDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ckeditor5, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ckeditor5 to 43.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-45613 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-45613 in your dependencies?
Find it across npm, including transitive dependencies.