NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2025-58064 — ckeditor5

Fix: ckeditor/ckeditor5@b210e90

CVE-2025-58064 is a Cross-site Scripting (XSS) vulnerability in ckeditor5. A fix is available for ckeditor5 — see the affected versions and patch details below.

CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package

Also known asGHSA-x9gp-vjh6-3wv6
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-58064.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs36th percentile — riskier than 36% of all scored CVEsHighest risk
0.00%0.31%0.61%0.92%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

269other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ckeditor5npm
1.3Mdownloads / week
@ckeditor/ckeditor5-clipboardnpm
1.2Mdownloads / week

Description

Impact

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration.

This vulnerability affects only installations where the editor configuration meets one of the following criteria:

Patches

The problem has been recognized and patched. The fix will be available in version 46.0.3 (and above), and explicitly in version 45.2.2.

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
📦npmckeditor5≥ 46.0.0&&< 46.0.346.0.3npm install ckeditor5@46.0.3
📦npm@ckeditor/ckeditor5-clipboard≥ 44.2.0&&< 45.2.245.2.2npm install @ckeditor/ckeditor5-clipboard@45.2.2
📦npmckeditor5≥ 44.2.0&&< 45.2.245.2.2npm install ckeditor5@45.2.2
📦npm@ckeditor/ckeditor5-clipboard≥ 46.0.0&&< 46.0.346.0.3npm install @ckeditor/ckeditor5-clipboard@46.0.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ckeditor5, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ckeditor5 to 46.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-58064 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects **only** installations where the editor configuration meets one of the following criteria: - [HTML embed plugin](https://ckeditor.com/docs/ckeditor5/latest/features/html/html-embed.html) is enabled - Custom plugi
O3 Security · Impact-Aware SCA

Is CVE-2025-58064 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-58064: ckeditor5 XSS — Fixed in 46.0.3