NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2022-31175 — @ckeditor/ckeditor5-markd…

MEDIUM

CVE-2022-31175 is a medium-severity (CVSS 5.8) Cross-site Scripting (XSS) vulnerability in @ckeditor/ckeditor5-markdown-gfm. A fix is available for @ckeditor/ckeditor5-markdown-gfm — see the affected versions and patch details below.

Cross-site scripting caused by the editor instance destroying process in ckeditor5

Also known asGHSA-42wq-rch8-6f6j
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31175.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.08%0.51%0.95%1.38%0.7%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

197other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@ckeditor/ckeditor5-markdown-gfmnpm
991Kdownloads / week
@ckeditor/ckeditor5-html-supportnpm
999Kdownloads / week
@ckeditor/ckeditor5-html-embednpm
997Kdownloads / week

Description

CKEditor 5 is a JavaScript rich text editor. A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages in versions prior to 35.0.1. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions. The affected packages are @ckeditor/ckeditor5-markdown-gfm, @ckeditor/ckeditor5-html-support, and @ckeditor/ckeditor5-html-embed. The specific conditions are 1) Using one of the affected packages. In case of ckeditor5-html-support and ckeditor5-html-embed, additionally, it was required to use a configuration that allows unsafe markup inside the editor. 2) Destroying the editor instance and 3) Initializing the editor on an element and using an element other than <textarea> as a base. The root cause of the issue was a mechanism responsible for updating the source element with the markup coming from the CKEditor 5 data pipeline after destroying the editor. This vulnerability might affect a small percent of integrators that depend on dynamic editor initialization/destroy and use Markdown, General HTML Support or HTML embed features. The problem has been recognized and patched. The fix is available in version 35.0.1. There are no known workarounds for this issue.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npm@ckeditor/ckeditor5-markdown-gfmall versions35.0.1npm install @ckeditor/ckeditor5-markdown-gfm@35.0.1
📦npm@ckeditor/ckeditor5-html-supportall versions35.0.1npm install @ckeditor/ckeditor5-html-support@35.0.1
📦npm@ckeditor/ckeditor5-html-embedall versions35.0.1npm install @ckeditor/ckeditor5-html-embed@35.0.1

Affected Products

3 products · 3 configurations
Application
ckeditor5-html-embedckeditor
< 35.0.1
range
Application
ckeditor5-html-supportckeditor
< 35.0.1
range
Application
ckeditor5-markdown-gfmckeditor
< 35.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @ckeditor/ckeditor5-markdown-gfm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @ckeditor/ckeditor5-markdown-gfm to 35.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31175 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

CKEditor 5 is a JavaScript rich text editor. A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages in versions prior to 35.0.1. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions. The affected packages are `@ckeditor/ckeditor5-markdown-gfm`, `@ckeditor/ckeditor5-html-support`, and `@ckeditor/ckeditor5-html-embed`. The specific conditions are 1) Using one of the affected packages. In case of `ckeditor5-html-support` and `ckeditor5-html-embed`, additionally, it was required to use a configuration that allow
O3 Security · Impact-Aware SCA

Is CVE-2022-31175 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-31175: @ckeditor/ckeditor5 — Fixed in 35.0.1