NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2025-32996 — http-proxy-middleware

MEDIUMFix: chimurai/http-proxy-middleware@0209760

CVE-2025-32996 is a medium-severity (CVSS 4) CWE-670 vulnerability in http-proxy-middleware. A fix is available for http-proxy-middleware — see the affected versions and patch details below.

http-proxy-middleware can call writeBody twice because "else if" is not used

Also known asGHSA-4www-5p9h-95mh
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-32996.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.32%0.64%0.97%0.2%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
http-proxy-middlewarenpm
30.8Mdownloads / week

Description

In http-proxy-middleware before 2.0.8 and 3.x before 3.0.4, writeBody can be called twice because "else if" is not used.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmhttp-proxy-middleware≥ 1.3.0&&< 2.0.82.0.8npm install http-proxy-middleware@2.0.8
📦npmhttp-proxy-middleware≥ 3.0.0&&< 3.0.43.0.4npm install http-proxy-middleware@3.0.4

Affected Products

1 product · 2 configurations
Application
http-proxy-middlewarechimurai
≥ 3.0.0 && < 3.0.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for http-proxy-middleware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update http-proxy-middleware to 2.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-32996 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2025-32996 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Developer Hub 1.6rhdh/rhdh-hub-rhel9:1.6.2-1750887220RHSA-2025:9966
Red Hat Developer Hub 1.7rhdh/rhdh-hub-rhel9:1.7.0-1754936470RHSA-2025:14090

Frequently Asked Questions

In http-proxy-middleware before 2.0.8 and 3.x before 3.0.4, writeBody can be called twice because "else if" is not used.
O3 Security · Impact-Aware SCA

Is CVE-2025-32996 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-32996: http-proxy-middleware — Fixed in 2.0.8