CVE-2025-32997 is a medium-severity (CVSS 4) CWE-754 vulnerability in http-proxy-middleware. A fix is available for http-proxy-middleware — see the affected versions and patch details below.
http-proxy-middleware allows fixRequestBody to proceed even if bodyParser has failed
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-32997.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
http-proxy-middlewarenpmDescription
In http-proxy-middleware before 2.0.9 and 3.x before 3.0.5, fixRequestBody proceeds even if bodyParser has failed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | http-proxy-middleware | ≥ 1.3.0&&< 2.0.9 | 2.0.9npm install http-proxy-middleware@2.0.9 |
| 📦npm | http-proxy-middleware | ≥ 3.0.0&&< 3.0.5 | 3.0.5npm install http-proxy-middleware@3.0.5 |
Affected Products
http-proxy-middlewarechimuraiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for http-proxy-middleware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update http-proxy-middleware to 2.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-32997 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-32997 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Developer Hub 1.6 | rhdh/rhdh-hub-rhel9:1.6.2-1750887220 | RHSA-2025:9966 |
| Red Hat Developer Hub 1.7 | rhdh/rhdh-hub-rhel9:1.7.0-1754936470 | RHSA-2025:14090 |
Frequently Asked Questions
Is CVE-2025-32997 in your dependencies?
Find it across npm, including transitive dependencies.