CVE-2024-21536 — http-proxy-middleware
Fix: chimurai/http-proxy-middleware@0b4274eCVE-2024-21536 is a Uncontrolled Resource Consumption vulnerability in http-proxy-middleware. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for http-proxy-middleware — see the affected versions and patch details below.
Denial of service in http-proxy-middleware
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-21536.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
http-proxy-middlewarenpmDescription
Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | http-proxy-middleware | all versions | 2.0.7npm install http-proxy-middleware@2.0.7 |
| 📦npm | http-proxy-middleware | ≥ 3.0.0&&< 3.0.3 | 3.0.3npm install http-proxy-middleware@3.0.3 |
Affected Products
http-proxy-middlewarechimuraiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for http-proxy-middleware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update http-proxy-middleware to 2.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-21536 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated with a Moderate impact for Red Hat products because an unauthenticated remote request can terminate the backend Node.js process, yet it does not compromise data confidentiality or system integrity. In typical Red Hat environments such as OpenShift container platforms and web consoles,…
Red Hat Product Security does not have any mitigation recommendations at this time.Source: Red Hat security advisory for CVE-2024-21536 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Discovery 1 for RHEL 9 | discovery/discovery-server-rhel9:1.12.0-1 | RHSA-2025:1249 |
| Red Hat Advanced Cluster Security 4.5 | advanced-cluster-security/rhacs-central-db-rhel8:4.5.9-1 | RHSA-2025:3928 |
| Red Hat Advanced Cluster Security 4.6 | advanced-cluster-security/rhacs-central-db-rhel8:4.6.5-1 | RHSA-2025:3929 |
| Red Hat Advanced Cluster Security 4.7 | advanced-cluster-security/rhacs-central-db-rhel8:4.7.2-2 | RHSA-2025:3930 |
| Red Hat Developer Hub 1.3 on RHEL 9 | rhdh/rhdh-hub-rhel9:1.3-124 | RHBA-2024:9054 |
| Red Hat Migration Toolkit for Containers 1.8 | rhmtc/openshift-migration-ui-rhel8:v1.8.7-2 | RHSA-2025:8510 |
| Red Hat OpenShift Service Mesh 2.6 for RHEL 8 | openshift-service-mesh/grafana-rhel8:2.6.3-2 | RHSA-2024:9627 |
| RHODF-4.14-RHEL-9 | odf4/ocs-client-console-rhel9:v4.14.18-2 | RHSA-2025:8551 |
Frequently Asked Questions
Is CVE-2024-21536 in your dependencies?
Find it across npm, including transitive dependencies.