NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Denial of service in http-proxy-middlewareGHSA-c7qv-q95q-8v27

HIGHFix: chimurai/http-proxy-middleware@0b4274e

GHSA-c7qv-q95q-8v27 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in http-proxy-middleware. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for http-proxy-middleware — see the affected versions and patch details below.

Also known asCVE-2024-21536
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for GHSA-c7qv-q95q-8v27.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.00%0.51%1.02%1.53%0.4%1.0%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
http-proxy-middlewarenpm
31.9Mdownloads / week

Description

Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmhttp-proxy-middlewareall versions2.0.7npm install http-proxy-middleware@2.0.7
📦npmhttp-proxy-middleware≥ 3.0.0&&< 3.0.33.0.3npm install http-proxy-middleware@3.0.3

Affected Products

1 product · 2 configurations
Application
http-proxy-middlewarechimurai
≥ 3.0.0 && < 3.0.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for http-proxy-middleware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update http-proxy-middleware to 2.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c7qv-q95q-8v27 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This vulnerability is rated with a Moderate impact for Red Hat products because an unauthenticated remote request can terminate the backend Node.js process, yet it does not compromise data confidentiality or system integrity. In typical Red Hat environments such as OpenShift container platforms and web consoles,…

Workaround published by Red Hat
Red Hat Product Security does not have any mitigation recommendations at this time.
Source: Red Hat security advisory for GHSA-c7qv-q95q-8v27 (CC BY 4.0)
ProductFixed inAdvisory
Discovery 1 for RHEL 9discovery/discovery-server-rhel9:1.12.0-1RHSA-2025:1249
Red Hat Advanced Cluster Security 4.5advanced-cluster-security/rhacs-central-db-rhel8:4.5.9-1RHSA-2025:3928
Red Hat Advanced Cluster Security 4.6advanced-cluster-security/rhacs-central-db-rhel8:4.6.5-1RHSA-2025:3929
Red Hat Advanced Cluster Security 4.7advanced-cluster-security/rhacs-central-db-rhel8:4.7.2-2RHSA-2025:3930
Red Hat Developer Hub 1.3 on RHEL 9rhdh/rhdh-hub-rhel9:1.3-124RHBA-2024:9054
Red Hat Migration Toolkit for Containers 1.8rhmtc/openshift-migration-ui-rhel8:v1.8.7-2RHSA-2025:8510
Red Hat OpenShift Service Mesh 2.6 for RHEL 8openshift-service-mesh/grafana-rhel8:2.6.3-2RHSA-2024:9627
RHODF-4.14-RHEL-9odf4/ocs-client-console-rhel9:v4.14.18-2RHSA-2025:8551

Frequently Asked Questions

Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.
O3 Security · Impact-Aware SCA

Is GHSA-c7qv-q95q-8v27 in your dependencies?

Find it across npm, including transitive dependencies.

Denial of service in http-proxy-middleware (High 7.5)