CVE-2024-29834 is a medium-severity (CVSS 6.4) CWE-863 vulnerability in org.apache.pulsar:pulsar-broker. A fix is available for org.apache.pulsar:pulsar-broker — see the affected versions and patch details below.
Apache Pulsar: Improper Authorization For Namespace and Topic Management Endpoints
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-29834.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-brokerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
This vulnerability allows authenticated users with produce or consume permissions to perform unauthorized operations on partitioned topics, such as unloading topics and triggering compaction. These management operations should be restricted to users with the tenant admin role or superuser role. An authenticated user with produce permission can create subscriptions and update subscription properties on partitioned topics, even though this should be limited to users with consume permissions. This impact analysis assumes that Pulsar has been configured with the default authorization provider. For custom authorization providers, the impact could be slightly different. Additionally, the vulnerability allows an authenticated user to read, create, modify, and delete namespace properties in any namespace in any tenant. In Pulsar, namespace properties are reserved for user provided metadata about the namespace.
This issue affects Apache Pulsar versions from 2.7.1 to 2.10.6, from 2.11.0 to 2.11.4, from 3.0.0 to 3.0.3, from 3.1.0 to 3.1.3, and from 3.2.0 to 3.2.1.
3.0 Apache Pulsar users should upgrade to at least 3.0.4. 3.1 and 3.2 Apache Pulsar users should upgrade to at least 3.2.2.
Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.pulsar:pulsar-broker | ≥ 2.7.1 | No fix |
| ☕Maven | org.apache.pulsar:pulsar-broker | ≥ 2.11.0 | No fix |
| ☕Maven | org.apache.pulsar:pulsar-broker | ≥ 3.0.0&&< 3.0.4 | 3.0.4org.apache.pulsar:pulsar-broker:3.0.4 |
| ☕Maven | org.apache.pulsar:pulsar-broker | ≥ 3.1.0 | No fix |
| ☕Maven | org.apache.pulsar:pulsar-broker | ≥ 3.2.0&&< 3.2.2 | 3.2.2org.apache.pulsar:pulsar-broker:3.2.2 |
Affected Products
pulsarapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.pulsar:pulsar-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2024-29834; check the affected-versions list above or the advisory for the patched release of org.apache.pulsar:pulsar-broker, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability in Apache Pulsar, rated as important severity, poses a notable risk due to its potential to compromise the integrity and security of partitioned topics and namespace properties. Authenticated users with produce or consume permissions can execute unauthorized actions such as unloading topics,…
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-29834 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2024-29834 in your dependencies?
Find it across Maven, including transitive dependencies.