CVE-2023-31007 — pulsar-broker
NONECVE-2023-31007 is a none-severity (CVSS 0) Improper Authentication vulnerability in org.apache.pulsar:pulsar-broker. A fix is available for org.apache.pulsar:pulsar-broker — see the affected versions and patch details below.
Apache Pulsar: Broker does not always disconnect client when authentication data expires
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-31007.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-brokerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker after authentication data expires if the client connected through the Pulsar Proxy when the broker is configured with authenticateOriginalAuthData=false or if a client connects directly to a broker with a specially crafted connect command when the broker is configured with authenticateOriginalAuthData=false.
This issue affects Apache Pulsar: through 2.9.4, from 2.10.0 through 2.10.3, 2.11.0.
2.9 Pulsar Broker users should upgrade to at least 2.9.5. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected. Any users running the Pulsar Broker for 2.8.* and earlier should upgrade to one of the above patched versions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.pulsar:pulsar-broker | ≥ 2.9.0&&< 2.10.4 | 2.10.4org.apache.pulsar:pulsar-broker:2.10.4 |
| ☕Maven | org.apache.pulsar:pulsar-broker | ≥ 2.11.0&&< 2.11.1 | 2.11.1org.apache.pulsar:pulsar-broker:2.11.1 |
Affected Products
pulsarapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.pulsar:pulsar-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.pulsar:pulsar-broker to 2.10.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-31007 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-31007 in your dependencies?
Find it across Maven, including transitive dependencies.