CVE-2022-33683 — pulsar-broker
MEDIUMCVE-2022-33683 is a medium-severity (CVSS 5.9) CWE-295 vulnerability in org.apache.pulsar:pulsar-broker. A fix is available for org.apache.pulsar:pulsar-broker — see the affected versions and patch details below.
Disabled Certificate Validation makes Broker, Proxy Admin Clients vulnerable to MITM attack
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-33683.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-proxy☕org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-proxy☕org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-proxy☕org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-proxyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Pulsar Brokers and Proxies create an internal Pulsar Admin Client that does not verify peer TLS certificates, even when tlsAllowInsecureConnection is disabled via configuration. The Pulsar Admin Client's intra-cluster and geo-replication HTTPS connections are vulnerable to man in the middle attacks, which could leak authentication data, configuration data, and any other data sent by these clients. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. This issue affects Apache Pulsar Broker and Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.pulsar:pulsar-broker | all versions | 2.7.5org.apache.pulsar:pulsar-broker:2.7.5 |
| ☕Maven | org.apache.pulsar:pulsar-proxy | all versions | 2.7.5org.apache.pulsar:pulsar-proxy:2.7.5 |
| ☕Maven | org.apache.pulsar:pulsar-broker | ≥ 2.8.0&&< 2.8.4 | 2.8.4org.apache.pulsar:pulsar-broker:2.8.4 |
| ☕Maven | org.apache.pulsar:pulsar-proxy | ≥ 2.8.0&&< 2.8.4 | 2.8.4org.apache.pulsar:pulsar-proxy:2.8.4 |
| ☕Maven | org.apache.pulsar:pulsar-broker | ≥ 2.9.0&&< 2.9.3 | 2.9.3org.apache.pulsar:pulsar-broker:2.9.3 |
| ☕Maven | org.apache.pulsar:pulsar-proxy | ≥ 2.9.0&&< 2.9.3 | 2.9.3org.apache.pulsar:pulsar-proxy:2.9.3 |
Affected Products
pulsarapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.pulsar:pulsar-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.pulsar:pulsar-broker to 2.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-33683 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-33683 in your dependencies?
Find it across Maven, including transitive dependencies.