NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2024-28098 — pulsar-broker

MEDIUM

CVE-2024-28098 is a medium-severity (CVSS 6.4) CWE-863 vulnerability in org.apache.pulsar:pulsar-broker. A fix is available for org.apache.pulsar:pulsar-broker — see the affected versions and patch details below.

Apache Pulsar: Improper Authorization For Topic-Level Policy Management

Also known asGHSA-g627-r579-rw35
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-28098.

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%0.73%1.47%2.20%0.2%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
☕org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-broker☕org.apache.pulsar:pulsar-broker

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role.

This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0.

2.10 Apache Pulsar users should upgrade to at least 2.10.6. 2.11 Apache Pulsar users should upgrade to at least 2.11.4. 3.0 Apache Pulsar users should upgrade to at least 3.0.3. 3.1 Apache Pulsar users should upgrade to at least 3.1.3. 3.2 Apache Pulsar users should upgrade to at least 3.2.1.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.pulsar:pulsar-broker≥ 3.2.0&&< 3.2.13.2.1org.apache.pulsar:pulsar-broker:3.2.1
☕Mavenorg.apache.pulsar:pulsar-broker≥ 3.1.0&&< 3.1.33.1.3org.apache.pulsar:pulsar-broker:3.1.3
☕Mavenorg.apache.pulsar:pulsar-broker≥ 3.0.0&&< 3.0.33.0.3org.apache.pulsar:pulsar-broker:3.0.3
☕Mavenorg.apache.pulsar:pulsar-broker≥ 2.11.0&&< 2.11.42.11.4org.apache.pulsar:pulsar-broker:2.11.4
☕Mavenorg.apache.pulsar:pulsar-broker≥ 2.7.1&&< 2.10.62.10.6org.apache.pulsar:pulsar-broker:2.10.6

Affected Products

1 product · 5 configurations
Application
pulsarapache
≥ 3.1.0 && < 3.1.3
1 version
3.2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.pulsar:pulsar-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.pulsar:pulsar-broker to 3.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-28098 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Apache Pulsar is not part of EAP - it's not present in the EAP dependency tree and not distributed in the product maven repository. EAP is not affected.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2024-28098 (CC BY 4.0)

Frequently Asked Questions

The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Apache Pulsar users should upgrade to at least 2.10.6. 2.11 Apache Pulsar users should upgrade to at least 2.11.4. 3.0 Apache Pulsar users should upgrade to at least 3.0.3. 3.1 Apa
O3 Security · Impact-Aware SCA

Is CVE-2024-28098 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-28098: pulsar-broker — Fixed in 3.2.1