CVE-2024-24549 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in org.apache.tomcat:tomcat-coyote. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat-coyote — see the affected versions and patch details below.
Apache Tomcat: HTTP/2 header handling DoS
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-24549.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 11.0.0-M1&&< 11.0.0-M17 | 11.0.0-M17org.apache.tomcat:tomcat-coyote:11.0.0-M17 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 10.1.0-M1&&< 10.1.19 | 10.1.19org.apache.tomcat:tomcat-coyote:10.1.19 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 9.0.0-M1&&< 9.0.86 | 9.0.86org.apache.tomcat:tomcat-coyote:9.0.86 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 8.5.0&&< 8.5.99 | 8.5.99org.apache.tomcat:tomcat-coyote:8.5.99 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 8.5.0&&< 8.5.99 | 8.5.99org.apache.tomcat.embed:tomcat-embed-core:8.5.99 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 9.0.0-M1&&< 9.0.86 | 9.0.86org.apache.tomcat.embed:tomcat-embed-core:9.0.86 |
Affected Products
tomcatapachedebian linuxdebianfedorafedoraprojectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-coyote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-coyote to 11.0.0-M17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-24549 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability presents an Important severity issue due to its potential to facilitate various forms of attack, particularly in the context of HTTP/2 protocol. By delaying the reset of HTTP/2 streams until after processing all headers, malicious actors can exploit this window to execute header manipulation…
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-24549 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| JWS 5.7.8 | tomcat | RHSA-2024:1319 |
| JWS 6.0.1 | tomcat | RHSA-2024:1325 |
| Red Hat Enterprise Linux 10 | tomcat-1:10.1.36-1.el10_0 | RHSA-2025:7497 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.87-1.el8_10.1 | RHSA-2024:3666 |
| Red Hat Enterprise Linux 8.8 Extended Update Support | tomcat-1:9.0.87-1.el8_8.2 | RHSA-2024:3814 |
| Red Hat Enterprise Linux 9 | tomcat-1:9.0.87-1.el9_4.1 | RHSA-2024:3307 |
| Red Hat Enterprise Linux 9.2 Extended Update Support | tomcat-1:9.0.87-1.el9_2.1 | RHSA-2024:3308 |
| Red Hat JBoss Web Server 5.7 on RHEL 7 | jws5-tomcat-0:9.0.62-41.redhat_00020.1.el7jws | RHSA-2024:1318 |
Frequently Asked Questions
Is CVE-2024-24549 in your dependencies?
Find it across Maven, including transitive dependencies.