CVE-2025-53506 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.apache.tomcat:tomcat-coyote. A fix is available for org.apache.tomcat:tomcat-coyote — see the affected versions and patch details below.
Apache Tomcat: DoS via excessive h2 streams at connection start
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-53506.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial settings frame that reduces the maximum permitted concurrent streams.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 11.0.0-M1&&< 11.0.9 | 11.0.9org.apache.tomcat:tomcat-coyote:11.0.9 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 10.1.0-M1&&< 10.1.43 | 10.1.43org.apache.tomcat:tomcat-coyote:10.1.43 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 9.0.0.M1&&< 9.0.107 | 9.0.107org.apache.tomcat:tomcat-coyote:9.0.107 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 8.5.0 | No fix |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 8.5.0 | No fix |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 9.0.0.M1&&< 9.0.107 | 9.0.107org.apache.tomcat.embed:tomcat-embed-core:9.0.107 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-coyote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-coyote to 11.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-53506 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-53506 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | tomcat9-1:9.0.87-5.el10_0.3 | RHSA-2025:14178 |
| Red Hat Enterprise Linux 10 | tomcat-1:10.1.36-1.el10_0.2 | RHSA-2025:14179 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.87-1.el8_10.6 | RHSA-2025:14177 |
| Red Hat Enterprise Linux 8.8 Telecommunications Update Service | tomcat-1:9.0.87-1.el8_8.7 | RHSA-2025:14182 |
| Red Hat Enterprise Linux 9 | tomcat-1:9.0.87-3.el9_6.3 | RHSA-2025:14181 |
| Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions | tomcat-1:9.0.87-1.el9_2.6 | RHSA-2025:14183 |
| Red Hat Enterprise Linux 9.4 Extended Update Support | tomcat-1:9.0.87-1.el9_4.6 | RHSA-2025:14180 |
| Red Hat JBoss Web Server 5.8.5 | jws5-tomcat | RHSA-2025:11696 |
Frequently Asked Questions
Is CVE-2025-53506 in your dependencies?
Find it across Maven, including transitive dependencies.