CVE-2023-5115 is a medium-severity (CVSS 6.3) CWE-36 vulnerability in ansible. A fix is available for ansible — see the affected versions and patch details below.
Ansible symlink attack vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ansibleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An absolute path traversal attack exists in the Ansible automation platform. This flaw allows an attacker to craft a malicious Ansible role and make the victim execute the role. A symlink can be used to overwrite a file outside of the extraction path.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ansible | all versions | 8.5.0pip install --upgrade 'ansible==8.5.0' |
Affected Products
debian linuxdebianansible automation platformredhatansible developerredhatansible insideredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ansible to 8.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5115 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.3 for RHEL 8 | ansible-core-0:2.14.11-1.el8ap | RHSA-2023:5701 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | ansible-core-0:2.15.5-1.el8ap | RHSA-2023:5758 |
Frequently Asked Questions
Is CVE-2023-5115 in your dependencies?
Find it across PyPI, including transitive dependencies.