NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2019-10206 — ansible

MEDIUMFix: ansible/ansible@4b5aed4

CVE-2019-10206 is a medium-severity (CVSS 6.5) CWE-522 vulnerability in ansible. A fix is available for ansible — see the affected versions and patch details below.

Ansible password prompts could expose passwords

Also known asGHSA-cqmr-rcpr-cxh3PYSEC-2019-145
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.67%1.34%2.02%0.2%1.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍ansible🐍ansible🐍ansible

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIansible≥ 2.8.0&&< 2.8.42.8.4pip install --upgrade 'ansible==2.8.4'
🐍PyPIansible≥ 2.7.0&&< 2.7.132.7.13pip install --upgrade 'ansible==2.7.13'
🐍PyPIansible≥ 2.6.0&&< 2.6.192.6.19pip install --upgrade 'ansible==2.6.19'

Affected Products

4 products · 6 configurations
OS
debian linuxdebian
1 version
10.0
Application
backports sleopensuse
1 version
15.0
OS
leapopensuse
1 version
15.1
Application
ansibleredhat
≥ 2.8.0 && < 2.8.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ansible to 2.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10206 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Ansible Engine 2.6 for RHEL 7ansible-0:2.6.19-1.el7aeRHSA-2019:2545
Red Hat Ansible Engine 2.7 for RHEL 7ansible-0:2.7.13-1.el7aeRHSA-2019:2544
Red Hat Ansible Engine 2.8 for RHEL 7ansible-0:2.8.4-1.el7aeRHSA-2019:2542
Red Hat Ansible Engine 2 for RHEL 7ansible-0:2.8.4-1.el7aeRHSA-2019:2543
Red Hat OpenStack Platform 13.0 (Queens)ansible-0:2.6.19-1.el7aeRHSA-2019:3789
Red Hat OpenStack Platform 14.0 (Rocky)ansible-0:2.6.19-1.el7aeRHSA-2019:3744
UbuntuMEDIUM

Frequently Asked Questions

ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
O3 Security · Impact-Aware SCA

Is CVE-2019-10206 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-10206: ansible — Fixed in 2.8.4