CVE-2019-14858 is a medium-severity (CVSS 5.5) CWE-117 vulnerability in ansible. A fix is available for ansible — see the affected versions and patch details below.
Ansible leaks sensitive information to logs when told not to
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ansible🐍ansible🐍ansible🐍ansibleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to the module will cause the task to fail before the no_log options in the sub parameters are processed. As a result, data in the sub parameter fields will not be masked and will be displayed if Ansible is run with increased verbosity and present in the module invocation arguments for the task.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ansible | ≥ 2.9.0a1&&< 2.9.0rc4 | 2.9.0rc4pip install --upgrade 'ansible==2.9.0rc4' |
| 🐍PyPI | ansible | ≥ 2.8.0a1&&< 2.8.6 | 2.8.6pip install --upgrade 'ansible==2.8.6' |
| 🐍PyPI | ansible | ≥ 2.7.0a1&&< 2.7.14 | 2.7.14pip install --upgrade 'ansible==2.7.14' |
| 🐍PyPI | ansible | ≥ 2.0&&< 2.6.20 | 2.6.20pip install --upgrade 'ansible==2.6.20' |
Affected Products
ansible engineredhatansible towerredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ansible to 2.9.0rc4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-14858 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Fixes for Red Hat OpenStack Platform (RHOSP) have been set to 'Moderate' because flaw exploitation requires running Ansible with increased verbosity which is not the RHOSP deployment default. Red Hat Gluster Storage no longer maintains its own version of Ansible. The fix will be provided from core Ansible.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Engine 2.6 for RHEL 7 | ansible-0:2.6.20-1.el7ae | RHSA-2019:3201 |
| Red Hat Ansible Engine 2.7 for RHEL 7 | ansible-0:2.7.14-1.el7ae | RHSA-2019:3202 |
| Red Hat Ansible Engine 2.8 for RHEL 7 | ansible-0:2.8.6-1.el7ae | RHSA-2019:3203 |
| Red Hat Ansible Engine 2 for RHEL 7 | ansible-0:2.8.6-1.el7ae | RHSA-2019:3207 |
| Red Hat OpenStack Platform 13.0 (Queens) | ansible-0:2.6.20-1.el7ae | RHSA-2020:0756 |
Frequently Asked Questions
Is CVE-2019-14858 in your dependencies?
Find it across PyPI, including transitive dependencies.