NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2019-14856 — ansible

MEDIUMFix: ansible/ansible#63351

CVE-2019-14856 is a medium-severity (CVSS 6.5) Improper Authentication vulnerability in ansible. A fix is available for ansible — see the affected versions and patch details below.

Ansible password prompts could expose passwords

Also known asGHSA-6fq2-x65v-v9h7PYSEC-2019-146
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%0.72%1.44%2.16%0.3%1.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍ansible🐍ansible🐍ansible

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A data disclosure flaw was found in ansible. Password prompts in ansible-playbook and ansible-cli tools could expose passwords with special characters as they are not properly wrapped. A password with special characters is exposed starting with the first of these special characters. The highest threat from this vulnerability is to data confidentiality.

This CVE exists due to an incomplete fix for CVE-2019-10206.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIansible≥ 2.8.0&&< 2.8.62.8.6pip install --upgrade 'ansible==2.8.6'
🐍PyPIansible≥ 2.7.0&&< 2.7.142.7.14pip install --upgrade 'ansible==2.7.14'
🐍PyPIansible≥ 2.6.0&&< 2.6.202.6.20pip install --upgrade 'ansible==2.6.20'

Affected Products

4 products · 6 configurations
Application
backports sleopensuse
1 version
15.0
OS
leapopensuse
1 version
15.1
Application
ansibleredhat
≥ 2.8.0 && < 2.8.6
range
Application
openstackredhat
1 version
13

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ansible to 2.8.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-14856 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Ansible Engine 2.6 for RHEL 7ansible-0:2.6.20-1.el7aeRHSA-2019:3201
Red Hat Ansible Engine 2.7 for RHEL 7ansible-0:2.7.14-1.el7aeRHSA-2019:3202
Red Hat Ansible Engine 2.8 for RHEL 7ansible-0:2.8.6-1.el7aeRHSA-2019:3203
Red Hat Ansible Engine 2 for RHEL 7ansible-0:2.8.6-1.el7aeRHSA-2019:3207
Red Hat OpenStack Platform 13.0 (Queens)ansible-0:2.6.20-1.el7aeRHSA-2020:0756

Frequently Asked Questions

A data disclosure flaw was found in ansible. Password prompts in ansible-playbook and ansible-cli tools could expose passwords with special characters as they are not properly wrapped. A password with special characters is exposed starting with the first of these special characters. The highest threat from this vulnerability is to data confidentiality. This CVE exists due to an incomplete fix for CVE-2019-10206.
O3 Security · Impact-Aware SCA

Is CVE-2019-14856 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-14856: ansible — Fixed in 2.8.6