GHSA-6fq2-x65v-v9h7 is a medium-severity (CVSS 6.5) Improper Authentication vulnerability in ansible. A fix is available for ansible — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ansible🐍ansible🐍ansibleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A data disclosure flaw was found in ansible. Password prompts in ansible-playbook and ansible-cli tools could expose passwords with special characters as they are not properly wrapped. A password with special characters is exposed starting with the first of these special characters. The highest threat from this vulnerability is to data confidentiality.
This CVE exists due to an incomplete fix for CVE-2019-10206.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ansible | ≥ 2.8.0&&< 2.8.6 | 2.8.6pip install --upgrade 'ansible==2.8.6' |
| 🐍PyPI | ansible | ≥ 2.7.0&&< 2.7.14 | 2.7.14pip install --upgrade 'ansible==2.7.14' |
| 🐍PyPI | ansible | ≥ 2.6.0&&< 2.6.20 | 2.6.20pip install --upgrade 'ansible==2.6.20' |
Affected Products
backports sleopensuseleapopensuseansibleredhatopenstackredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ansible to 2.8.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6fq2-x65v-v9h7 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Engine 2.6 for RHEL 7 | ansible-0:2.6.20-1.el7ae | RHSA-2019:3201 |
| Red Hat Ansible Engine 2.7 for RHEL 7 | ansible-0:2.7.14-1.el7ae | RHSA-2019:3202 |
| Red Hat Ansible Engine 2.8 for RHEL 7 | ansible-0:2.8.6-1.el7ae | RHSA-2019:3203 |
| Red Hat Ansible Engine 2 for RHEL 7 | ansible-0:2.8.6-1.el7ae | RHSA-2019:3207 |
| Red Hat OpenStack Platform 13.0 (Queens) | ansible-0:2.6.20-1.el7ae | RHSA-2020:0756 |
Frequently Asked Questions
Is GHSA-6fq2-x65v-v9h7 in your dependencies?
Find it across PyPI, including transitive dependencies.