NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Ansible symlink attack vulnerabilityGHSA-jpvw-p8pr-9g2x

MEDIUMFix: ansible/ansible@1e93068

GHSA-jpvw-p8pr-9g2x is a medium-severity (CVSS 6.3) CWE-36 vulnerability in ansible. A fix is available for ansible — see the affected versions and patch details below.

Also known asCVE-2023-5115PYSEC-2026-1120
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.16%0.61%1.06%1.51%0.7%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍ansible

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An absolute path traversal attack exists in the Ansible automation platform. This flaw allows an attacker to craft a malicious Ansible role and make the victim execute the role. A symlink can be used to overwrite a file outside of the extraction path.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIansibleall versions8.5.0pip install --upgrade 'ansible==8.5.0'

Affected Products

4 products · 8 configurations
OS
debian linuxdebian
1 version
10.0
Application
ansible automation platformredhat
3 versions
1.22.32.4
Application
ansible developerredhat
2 versions
1.01.1
Application
ansible insideredhat
2 versions
1.11.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ansible to 8.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jpvw-p8pr-9g2x is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Ansible Automation Platform 2.3 for RHEL 8ansible-core-0:2.14.11-1.el8apRHSA-2023:5701
Red Hat Ansible Automation Platform 2.4 for RHEL 8ansible-core-0:2.15.5-1.el8apRHSA-2023:5758

Frequently Asked Questions

An absolute path traversal attack exists in the Ansible automation platform. This flaw allows an attacker to craft a malicious Ansible role and make the victim execute the role. A symlink can be used to overwrite a file outside of the extraction path.
O3 Security · Impact-Aware SCA

Is GHSA-jpvw-p8pr-9g2x in your dependencies?

Find it across PyPI, including transitive dependencies.

Ansible symlink attack vulnerability (Medium 6.3)