CVE-2023-24831 — iotdb-grafana-connector
CRITICALCVE-2023-24831 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in org.apache.iotdb:iotdb-grafana-connector. A fix is available for org.apache.iotdb:iotdb-grafana-connector — see the affected versions and patch details below.
Apache IoTDB grafana-connector Login Bypass Vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-24831.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.iotdb:iotdb-grafana-connector🐍apache-iotdbReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Improper Authentication vulnerability in Apache Software Foundation Apache IoTDB. This issue affects Apache IoTDB Grafana Connector from 0.13.0 through 0.13.3.
Attackers could log in without authorization. This is fixed in 0.13.4.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.iotdb:iotdb-grafana-connector | ≥ 0.13.0&&< 0.13.4 | 0.13.4org.apache.iotdb:iotdb-grafana-connector:0.13.4 |
| 🐍PyPI | apache-iotdb | ≥ 0.13.0&&< 0.13.5 | 0.13.5pip install --upgrade 'apache-iotdb==0.13.5' |
Affected Products
iotdbapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.iotdb:iotdb-grafana-connector, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.iotdb:iotdb-grafana-connector to 0.13.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-24831 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-24831 in your dependencies?
Find it across Maven, PyPI, including transitive dependencies.