NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2022-38369 — iotdb-server

HIGH

CVE-2022-38369 is a high-severity (CVSS 8.8) CWE-384 vulnerability in org.apache.iotdb:iotdb-server. A fix is available for org.apache.iotdb:iotdb-server — see the affected versions and patch details below.

Login check vulnerability by session Id

Also known asGHSA-g6vm-3ch8-c6jqPYSEC-2022-43069
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.55%1.16%1.76%2.37%1.9%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.iotdb:iotdb-server🐍apache-iotdb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Apache IoTDB version 0.13.0 is vulnerable by session id attack. Users should upgrade to version 0.13.1 which addresses this issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.iotdb:iotdb-serverall versions0.13.1org.apache.iotdb:iotdb-server:0.13.1
🐍PyPIapache-iotdball versions0.13.1pip install --upgrade 'apache-iotdb==0.13.1'

Affected Products

1 product · 1 configurations
Application
iotdbapache
1 version
0.13.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.iotdb:iotdb-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.iotdb:iotdb-server to 0.13.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-38369 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Apache IoTDB version 0.13.0 is vulnerable by session id attack. Users should upgrade to version 0.13.1 which addresses this issue.
O3 Security · Impact-Aware SCA

Is CVE-2022-38369 in your dependencies?

Find it across Maven, PyPI, including transitive dependencies.

CVE-2022-38369: iotdb-server — Fixed in 0.13.1