CVE-2023-46226 — iotdb-core
CRITICALCVE-2023-46226 is a critical-severity (CVSS 9.8) Code Injection vulnerability in org.apache.iotdb:iotdb-core. A fix is available for org.apache.iotdb:iotdb-core — see the affected versions and patch details below.
Apache IoTDB: Remote Code Execution (RCE) risk via the UDF
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-46226.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.iotdb:iotdb-core🐍apache-iotdbReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Remote Code Execution vulnerability in Apache IoTDB. This issue affects Apache IoTDB from 1.0.0 through 1.2.2.
Users are recommended to upgrade to version 1.3.0, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.iotdb:iotdb-core | ≥ 1.0.0&&< 1.3.0 | 1.3.0org.apache.iotdb:iotdb-core:1.3.0 |
| 🐍PyPI | apache-iotdb | ≥ 1.0.0&&< 1.3.0 | 1.3.0pip install --upgrade 'apache-iotdb==1.3.0' |
Affected Products
iotdbapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.iotdb:iotdb-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.iotdb:iotdb-core to 1.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-46226 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2023-46226 in your dependencies?
Find it across Maven, PyPI, including transitive dependencies.