NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2024-24780 — iotdb-core

CRITICALFix: apache/iotdb#14365

CVE-2024-24780 is a critical-severity (CVSS 9.8) Code Injection vulnerability in org.apache.iotdb:iotdb-core. A fix is available for org.apache.iotdb:iotdb-core — see the affected versions and patch details below.

Apache IoTDB: Remote Code Execution with untrusted URI of User-defined function

Also known asGHSA-f4rq-f4j9-f6rmPYSEC-2025-59
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-24780.

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.80%1.25%1.69%2.13%1.6%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.iotdb:iotdb-core🐍apache-iotdb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Remote Code Execution with untrusted URI of UDF vulnerability in Apache IoTDB. The attacker who has privilege to create UDF can register malicious function from untrusted URI.

This issue affects Apache IoTDB: from 1.0.0 before 1.3.4.

Users are recommended to upgrade to version 1.3.4, which fixes the issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.iotdb:iotdb-core≥ 1.0.0&&< 1.3.41.3.4org.apache.iotdb:iotdb-core:1.3.4
🐍PyPIapache-iotdb≥ 1.0.0&&< 1.3.41.3.4pip install --upgrade 'apache-iotdb==1.3.4'

Affected Products

1 product · 1 configurations
Application
iotdbapache
≥ 1.0.0 && < 1.3.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.iotdb:iotdb-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.iotdb:iotdb-core to 1.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-24780 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Remote Code Execution with untrusted URI of UDF vulnerability in Apache IoTDB. The attacker who has privilege to create UDF can register malicious function from untrusted URI. This issue affects Apache IoTDB: from 1.0.0 before 1.3.4. Users are recommended to upgrade to version 1.3.4, which fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2024-24780 in your dependencies?

Find it across Maven, PyPI, including transitive dependencies.

CVE-2024-24780: iotdb-core RCE — Fixed in 1.3.4