CVE-2025-55017 is a critical-severity (CVSS 9.1) Path Traversal vulnerability in org.apache.iotdb:iotdb-server. A fix is available for org.apache.iotdb:iotdb-server — see the affected versions and patch details below.
Apache IoTDB has a Path Traversal vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-55017.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.iotdb:iotdb-server☕org.apache.iotdb:iotdb-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 2.0.0 before 2.0.6, from 1.0.0 before 1.3.6.
Users are recommended to upgrade to version 1.3.6 and 2.0.6, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.iotdb:iotdb-server | ≥ 2.0.0&&< 2.0.6 | 2.0.6org.apache.iotdb:iotdb-server:2.0.6 |
| ☕Maven | org.apache.iotdb:iotdb-server | ≥ 1.0.0&&< 1.3.6 | 1.3.6org.apache.iotdb:iotdb-server:1.3.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.iotdb:iotdb-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.iotdb:iotdb-server to 2.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-55017 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2025-55017 in your dependencies?
Find it across Maven, including transitive dependencies.