CVE-2022-38370 — iotdb-grafana-connector
HIGHCVE-2022-38370 is a high-severity (CVSS 7.5) CWE-862 vulnerability in org.apache.iotdb:iotdb-grafana-connector. A fix is available for org.apache.iotdb:iotdb-grafana-connector — see the affected versions and patch details below.
No authorization of DatabaseConnectController in grafana-connector.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.iotdb:iotdb-grafana-connectorReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache IoTDB grafana-connector version 0.13.0 contains an interface without authorization, which may expose the internal structure of a database. Users should upgrade to version 0.13.1, which addresses this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.iotdb:iotdb-grafana-connector | all versions | 0.13.1org.apache.iotdb:iotdb-grafana-connector:0.13.1 |
Affected Products
iotdbapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.iotdb:iotdb-grafana-connector, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.iotdb:iotdb-grafana-connector to 0.13.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-38370 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-38370 in your dependencies?
Find it across Maven, including transitive dependencies.