CVE-2022-47951 — cinder
MEDIUMCVE-2022-47951 is a medium-severity (CVSS 5.7) Path Traversal vulnerability in cinder. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cinder — see the affected versions and patch details below.
OpenStack Cinder, glance, and Nova vulnerable to Path Traversal
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-47951.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
cinder🐍cinder🐍glance🐍glance🐍nova🐍novaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in OpenStack Cinder before 19.1.2, 20.x before 20.0.2, and 21.0.0; Glance before 23.0.1, 24.x before 24.1.1, and 25.0.0; and Nova before 24.1.2, 25.x before 25.0.2, and 26.0.0. By supplying a specially created VMDK flat image that references a specific backing file path, an authenticated user may convince systems to return a copy of that file's contents from the server, resulting in unauthorized access to potentially sensitive data.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | cinder | all versions | 19.1.2pip install --upgrade 'cinder==19.1.2' |
| 🐍PyPI | cinder | ≥ 20.0.0&&< 20.0.2 | 20.0.2pip install --upgrade 'cinder==20.0.2' |
| 🐍PyPI | glance | all versions | 23.0.1pip install --upgrade 'glance==23.0.1' |
| 🐍PyPI | glance | ≥ 24.0.0&&< 24.1.1 | 24.1.1pip install --upgrade 'glance==24.1.1' |
| 🐍PyPI | nova | all versions | 24.1.2pip install --upgrade 'nova==24.1.2' |
| 🐍PyPI | nova | ≥ 25.0.0&&< 25.0.2 | 25.0.2pip install --upgrade 'nova==25.0.2' |
Affected Products
debian linuxdebiancinderopenstackglanceopenstacknovaopenstackResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cinder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cinder to 19.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-47951 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 13.0 - ELS | openstack-nova-1:17.0.13-40.el7ost | RHSA-2023:1278 |
| Red Hat OpenStack Platform 13.0 - ELS | openstack-cinder-1:12.0.10-27.el7ost | RHSA-2023:1279 |
| Red Hat OpenStack Platform 13.0 - ELS | openstack-glance-1:16.0.1-13.el7ost | RHSA-2023:1280 |
| Red Hat OpenStack Platform 17.0 | openstack-nova-1:23.2.2-0.20221209190753.7074ac0.el9ost | RHSA-2023:1015 |
| Red Hat OpenStack Platform 17.0 | openstack-cinder-1:18.2.1-0.20230202190311.1776695.el9ost | RHSA-2023:1016 |
| Red Hat OpenStack Platform 17.0 | openstack-glance-1:22.1.1-0.20220919210603.677c89c.el9ost | RHSA-2023:1017 |
Frequently Asked Questions
Is CVE-2022-47951 in your dependencies?
Find it across PyPI, including transitive dependencies.