NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

OpenStack Cinder, glance, and Nova vulnerable to Path TraversalGHSA-7h75-hwxx-qpgc

MEDIUM

GHSA-7h75-hwxx-qpgc is a medium-severity (CVSS 5.7) Path Traversal vulnerability in cinder. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cinder — see the affected versions and patch details below.

Also known asCVE-2022-47951PYSEC-2026-2411PYSEC-2026-2490PYSEC-2026-868
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-7h75-hwxx-qpgc.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.11%0.59%1.06%1.53%0.7%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐍cinder🐍cinder🐍glance🐍glance🐍nova🐍nova

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in OpenStack Cinder before 19.1.2, 20.x before 20.0.2, and 21.0.0; Glance before 23.0.1, 24.x before 24.1.1, and 25.0.0; and Nova before 24.1.2, 25.x before 25.0.2, and 26.0.0. By supplying a specially created VMDK flat image that references a specific backing file path, an authenticated user may convince systems to return a copy of that file's contents from the server, resulting in unauthorized access to potentially sensitive data.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIcinderall versions19.1.2pip install --upgrade 'cinder==19.1.2'
🐍PyPIcinder≥ 20.0.0&&< 20.0.220.0.2pip install --upgrade 'cinder==20.0.2'
🐍PyPIglanceall versions23.0.1pip install --upgrade 'glance==23.0.1'
🐍PyPIglance≥ 24.0.0&&< 24.1.124.1.1pip install --upgrade 'glance==24.1.1'
🐍PyPInovaall versions24.1.2pip install --upgrade 'nova==24.1.2'
🐍PyPInova≥ 25.0.0&&< 25.0.225.0.2pip install --upgrade 'nova==25.0.2'

Affected Products

4 products · 8 configurations
OS
debian linuxdebian
2 versions
10.011.0
Application
cinderopenstack
≥ 20.0.0 && ≤ 19.1.2
range
Application
glanceopenstack
≥ 24.0.0 && < 24.1.1
range
Application
novaopenstack
≥ 25.0.0 && < 25.0.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cinder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cinder to 19.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7h75-hwxx-qpgc is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenStack Platform 13.0 - ELSopenstack-nova-1:17.0.13-40.el7ostRHSA-2023:1278
Red Hat OpenStack Platform 13.0 - ELSopenstack-cinder-1:12.0.10-27.el7ostRHSA-2023:1279
Red Hat OpenStack Platform 13.0 - ELSopenstack-glance-1:16.0.1-13.el7ostRHSA-2023:1280
Red Hat OpenStack Platform 17.0openstack-nova-1:23.2.2-0.20221209190753.7074ac0.el9ostRHSA-2023:1015
Red Hat OpenStack Platform 17.0openstack-cinder-1:18.2.1-0.20230202190311.1776695.el9ostRHSA-2023:1016
Red Hat OpenStack Platform 17.0openstack-glance-1:22.1.1-0.20220919210603.677c89c.el9ostRHSA-2023:1017

Frequently Asked Questions

An issue was discovered in OpenStack Cinder before 19.1.2, 20.x before 20.0.2, and 21.0.0; Glance before 23.0.1, 24.x before 24.1.1, and 25.0.0; and Nova before 24.1.2, 25.x before 25.0.2, and 26.0.0. By supplying a specially created VMDK flat image that references a specific backing file path, an authenticated user may convince systems to return a copy of that file's contents from the server, resulting in unauthorized access to potentially sensitive data.
O3 Security · Impact-Aware SCA

Is GHSA-7h75-hwxx-qpgc in your dependencies?

Find it across PyPI, including transitive dependencies.

OpenStack Cinder, glance, and Nova vulnerable to Path…