CVE-2015-5162 is a high-severity (CVSS 7.5) CWE-399 vulnerability in cinder. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cinder — see the affected versions and patch details below.
OpenStack Cinder, Glance, and Nova contain Uncontrolled Resource Consumption
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
cinder🐍cinder🐍glance🐍novaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The image parser in OpenStack Cinder prior to 7.0.2, and 8.0.0 and above, prior to 9.0.0; Glance prior to 14.00; and Nova prior to 12.0.4 does not properly limit qemu-img calls, which might allow attackers to cause a denial of service (memory and disk consumption) via a crafted disk image. This issue is patched in Cinder 7.0.2 and 9.0.0; Glance 14.0.0; and Nova 12.0.4
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | cinder | all versions | 7.0.2pip install --upgrade 'cinder==7.0.2' |
| 🐍PyPI | cinder | ≥ 8.0.0&&< 9.0.0 | 9.0.0pip install --upgrade 'cinder==9.0.0' |
| 🐍PyPI | glance | all versions | 14.0.0pip install --upgrade 'glance==14.0.0' |
| 🐍PyPI | nova | all versions | 12.0.4pip install --upgrade 'nova==12.0.4' |
Affected Products
cinderopenstackglanceopenstacknovaopenstackResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cinder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cinder to 7.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5162 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | openstack-cinder-0:2014.1.5-9.el6ost | RHSA-2017:0165 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 | openstack-cinder-0:2014.1.5-9.el7ost | RHSA-2017:0153 |
| Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 | openstack-cinder-0:2014.2.4-11.el7ost | RHSA-2017:0156 |
| Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 | openstack-cinder-0:2015.1.3-12.el7ost | RHSA-2017:0282 |
| Red Hat OpenStack Platform 8.0 (Liberty) | openstack-cinder-1:7.0.3-1.el7ost | RHSA-2016:2991 |
| Red Hat OpenStack Platform 9.0 (Mitaka) | openstack-cinder-1:8.1.1-4.el7ost | RHSA-2016:2923 |
Frequently Asked Questions
Is CVE-2015-5162 in your dependencies?
Find it across PyPI, including transitive dependencies.