CVE-2013-2255 is a medium-severity (CVSS 5.9) CWE-295 vulnerability in python-keystoneclient. A fix is available for python-keystoneclient — see the affected versions and patch details below.
OpenStack Keystone and other components vulnerable to Improper Certificate Validation
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
python-keystoneclient🐍cinder🐍neutron🐍keystoneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
HTTPSConnections in OpenStack Keystone 2013, OpenStack Compute 2013.1, and possibly other OpenStack components, fail to validate server-side SSL certificates.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | python-keystoneclient | all versions | 0.4.0pip install --upgrade 'python-keystoneclient==0.4.0' |
| 🐍PyPI | cinder | all versions | 7.0.0a0pip install --upgrade 'cinder==7.0.0a0' |
| 🐍PyPI | neutron | all versions | 7.0.0a0pip install --upgrade 'neutron==7.0.0a0' |
| 🐍PyPI | keystone | all versions | 8.0.0a0pip install --upgrade 'keystone==8.0.0a0' |
Affected Products
debian linuxdebiancomputeopenstackkeystoneopenstackopenstackredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for python-keystoneclient, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update python-keystoneclient to 0.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-2255 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2013-2255 in your dependencies?
Find it across PyPI, including transitive dependencies.