CVE-2014-0105 — python-keystoneclient
MEDIUMCVE-2014-0105 is a medium-severity (CVSS 6) CWE-255 vulnerability in python-keystoneclient. A fix is available for python-keystoneclient — see the affected versions and patch details below.
python-keystoneclient vulnerable to context confusion in Keystone auth_token middleware
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
python-keystoneclientReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A context confusion vulnerability was identified in Keystone auth_token middleware (shipped in python-keystoneclient) before 0.7.0. By doing repeated requests, with sufficient load on the target system, an authenticated user may in certain situations assume another authenticated user's complete identity and multi-tenant authorizations, potentially resulting in a privilege escalation. Note that it is related to a bad interaction between eventlet and python-memcached that should be avoided if the calling process already monkey-patches "thread" to use eventlet. Only keystone middleware setups using auth_token with memcache are vulnerable.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | python-keystoneclient | all versions | 0.7.0pip install --upgrade 'python-keystoneclient==0.7.0' |
Affected Products
python-keystoneclientopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for python-keystoneclient, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update python-keystoneclient to 0.7.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0105 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| OpenStack 3 for RHEL 6 | python-keystoneclient-1:0.2.3-8.el6ost | RHSA-2014:0442 |
| OpenStack 4 for RHEL 6 | python-keystoneclient-1:0.7.1-2.el6ost | RHSA-2014:0382 |
| Red Hat Storage 2.1 | python-keystoneclient-1:0.7.1-2.el6ost | RHSA-2014:0409 |
Frequently Asked Questions
Is CVE-2014-0105 in your dependencies?
Find it across PyPI, including transitive dependencies.