NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2020-10755 — cinder

MEDIUMFix: openstack/cinder@ba785ee

CVE-2020-10755 is a medium-severity (CVSS 6.5) CWE-522 vulnerability in cinder. A fix is available for cinder — see the affected versions and patch details below.

Openstack cinder Improper handling of ScaleIO backend credentials

Also known asGHSA-v3m2-pg96-w33mPYSEC-2020-228PYSEC-2026-891
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.16%1.74%0.2%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐍cinder🐍cinder🐍cinder🐍os-brick🐍os-brick🐍os-brick

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the connection_info element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, and retrieve a username and password that may be used to connect to another user's volume. Additionally, these credentials are valid for the ScaleIO or VxFlex OS Management API, should an attacker discover the Management API endpoint. Source: OpenStack project

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIcinder≥ 14.0.0&&< 14.1.014.1.0pip install --upgrade 'cinder==14.1.0'
🐍PyPIcinder≥ 15.0.0&&< 15.2.015.2.0pip install --upgrade 'cinder==15.2.0'
🐍PyPIcinder≥ 16.0.0&&< 16.1.016.1.0pip install --upgrade 'cinder==16.1.0'
🐍PyPIos-brick≥ 2.8.0&&< 2.8.62.8.6pip install --upgrade 'os-brick==2.8.6'
🐍PyPIos-brick≥ 2.10.0&&< 2.10.42.10.4pip install --upgrade 'os-brick==2.10.4'
🐍PyPIos-brick≥ 3.0.0&&< 3.0.23.0.2pip install --upgrade 'os-brick==3.0.2'

Affected Products

2 products · 5 configurations
OS
ubuntu linuxcanonical
2 versions
18.0420.04
Application
openstack-cinderredhat
≥ 16.0.0 && < 16.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cinder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cinder to 14.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-10755 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

In addition to the software updates for this flaw, you must deploy a new configuration file on compute nodes, cinder nodes, and anywhere you would perform a volume attachment in your deployment. For detailed information, refer to referenced article.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2020-10755 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat OpenStack Platform 13.0 (Queens)openstack-cinder-1:12.0.10-19.el7ostRHSA-2020:4391
Red Hat OpenStack Platform 16.1openstack-cinder-1:15.3.1-1.20200914173114.00ac80b.el8ostRHSA-2020:4283

Frequently Asked Questions

An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the ``connection_info`` element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, a
O3 Security · Impact-Aware SCA

Is CVE-2020-10755 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2020-10755: cinder — Fixed in 14.1.0