CVE-2022-31148 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in shopware/shopware. A fix is available for shopware/shopware — see the affected versions and patch details below.
Shopware vulnerable to persistent cross site scripting (XSS) in customer module
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
shopware/shopwareReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Persistent XSS in customer module
Patches
We recommend updating to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview.
For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
References
https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | shopware/shopware | ≥ 5.7.0&&< 5.7.14 | 5.7.14composer require shopware/shopware:^5.7.14 |
Affected Products
shopwareshopwareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shopware/shopware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update shopware/shopware to 5.7.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31148 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-31148 in your dependencies?
Find it across Packagist, including transitive dependencies.