Shopware Remote Code Execution VulnerabilityGHSA-q3g4-2vw9-xv27
CRITICALFix: shopware5/shopware@14299e9GHSA-q3g4-2vw9-xv27 is a critical-severity (CVSS 9.8) vulnerability in shopware/shopware. A fix is available for shopware/shopware — see the affected versions and patch details below.
Real-World Exposure
shopware/shopware🐘shopware/shopwareReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Under certain circumstances, it’s possible to execute an unauthorized foreign code in Shopware. This is a critical security vulnerability that could affect the entire system. All Shopware versions including Shopware 5.2.14 are affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | shopware/shopware | ≥ 4.0.0&&< 5.2.15 | 5.2.15composer require shopware/shopware:^5.2.15 |
| 🐘Packagist | shopware/shopware | all versions | 1.0.8composer require shopware/shopware:^1.0.8 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shopware/shopware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update shopware/shopware to 5.2.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q3g4-2vw9-xv27 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-q3g4-2vw9-xv27 in your dependencies?
Find it across Packagist, including transitive dependencies.