CVE-2025-67648 is a high-severity (CVSS 7.1) Cross-site Scripting (XSS) vulnerability in shopware/shopware. A fix is available for shopware/shopware — see the affected versions and patch details below.
Shopware's inproper input validation can lead to Reflected XSS through Storefront Login Page
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-67648.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
shopware/shopware🐘shopware/storefront🐘shopware/shopware🐘shopware/storefrontReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
By exploiting the XSS vulnerabilities, malicious actors can perform harmful actions in the user's web browser in the session context of the affected user. Some examples of this include, but are not limited to: Obtaining user session tokens. Performing administrative actions (when an administrative user is affected). These vulnerabilities pose a high security risk. Since a sensitive cookie is not configured with the HttpOnly attribute and administrator JWTs are stored in sessionStorage, any successful XSS attack could enable the theft of session cookies and administrative tokens.
Description
A request parameter from the URL of the login page is directly rendered within the Twig template of the Storefront login page without further processing or input validation. This allows direct code injection into the template via the URL parameter. An attacker can create malicious links that could be used in a phishing attack. The parameter waitTime lacks proper input validation.
The attack can be tested with the following URL pattern:
/account/login?loginError=1&waitTime=<a%20href%3D"https%3A%2F%2Fde.wikipedia.org%2Fwiki%2FPhishing">Here<%2Fa>
The same applies to the errorSnippet parameter:
/account/login?loginError=1&errorSnippet=Reset%20your%20password%20%3Ca%20href%3D%22https%3A%2F%2Fde.wikipedia.org%2Fwiki%2FPhishing%22%3Ehere%3C%2Fa%3E.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | shopware/shopware | ≥ 6.4.6.0&&< 6.6.10.10 | 6.6.10.10composer require shopware/shopware:^6.6.10.10 |
| 🐘Packagist | shopware/storefront | ≥ 6.4.6.0&&< 6.6.10.10 | 6.6.10.10composer require shopware/storefront:^6.6.10.10 |
| 🐘Packagist | shopware/shopware | ≥ 6.7.0.0&&< 6.7.5.1 | 6.7.5.1composer require shopware/shopware:^6.7.5.1 |
| 🐘Packagist | shopware/storefront | ≥ 6.7.0.0&&< 6.7.5.1 | 6.7.5.1composer require shopware/storefront:^6.7.5.1 |
Affected Products
shopwareshopwareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shopware/shopware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update shopware/shopware to 6.6.10.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-67648 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2025-67648 in your dependencies?
Find it across Packagist, including transitive dependencies.