NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

Shopware Remote Code Execution VulnerabilityGHSA-83jv-4prm-34g7

CRITICALFix: shopware5/shopware@8f6a7ce

GHSA-83jv-4prm-34g7 is a critical-severity (CVSS 9.8) vulnerability in shopware/shopware. A fix is available for shopware/shopware — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Dec 6, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐘shopware/shopware

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Under certain circumstances it is possible to execute an authorized foreign code in Shopware version prior to 5.2.25.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistshopware/shopware≥ 4.2.0&&< 5.2.255.2.25composer require shopware/shopware:^5.2.25

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shopware/shopware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update shopware/shopware to 5.2.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-83jv-4prm-34g7 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Under certain circumstances it is possible to execute an authorized foreign code in Shopware version prior to 5.2.25.
O3 Security · Impact-Aware SCA

Is GHSA-83jv-4prm-34g7 in your dependencies?

Find it across Packagist, including transitive dependencies.

Shopware Remote Code Execution Vulnerability