GHSA-jqr7-5h7r-ch8p is a medium-severity (CVSS 6.1) vulnerability in shopware/shopware. A fix is available for shopware/shopware — see the affected versions and patch details below.
Real-World Exposure
shopware/shopwareReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A non-persistent Cross-Site Scripting (XSS) vulnerability has been identified in the Shopware eCommerce platform within the frontend. This vulnerability may allow an attacker to inject and execute malicious scripts in the context of a victim's web browser.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | shopware/shopware | ≥ 5.2.0&&< 5.3.7 | 5.3.7composer require shopware/shopware:^5.3.7 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shopware/shopware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update shopware/shopware to 5.3.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jqr7-5h7r-ch8p is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-jqr7-5h7r-ch8p in your dependencies?
Find it across Packagist, including transitive dependencies.