CVE-2020-25827 — core
HIGHCVE-2020-25827 is a high-severity (CVSS 7.5) CWE-307 vulnerability in mediawiki/core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mediawiki/core — see the affected versions and patch details below.
OATHAuth extension in MediaWiki is not implementing rate limit
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mediawiki/core🐘mediawiki/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in the OATHAuth extension in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4. For Wikis using OATHAuth on a farm/cluster (such as via CentralAuth), rate limiting of OATH tokens is only done on a single site level. Thus, multiple requests can be made across many wikis/sites concurrently.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/core | ≥ 1.31.0&&< 1.31.9 | 1.31.9composer require mediawiki/core:^1.31.9 |
| 🐘Packagist | mediawiki/core | ≥ 1.32.0&&< 1.34.3 | 1.34.3composer require mediawiki/core:^1.34.3 |
Affected Products
fedorafedoraprojectmediawikimediawikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/core to 1.31.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-25827 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-25827 in your dependencies?
Find it across Packagist, including transitive dependencies.