CVE-2019-16738 — core
MEDIUMCVE-2019-16738 is a medium-severity (CVSS 5.3) CWE-862 vulnerability in mediawiki/core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mediawiki/core — see the affected versions and patch details below.
MediaWiki information disclosure
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mediawiki/core🐘mediawiki/core🐘mediawiki/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In MediaWiki through 1.33.0, Special:Redirect allows information disclosure of suppressed usernames via a User ID Lookup.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/core | ≥ 1.31.0&&< 1.31.4 | 1.31.4composer require mediawiki/core:^1.31.4 |
| 🐘Packagist | mediawiki/core | ≥ 1.32.0&&< 1.32.4 | 1.32.4composer require mediawiki/core:^1.32.4 |
| 🐘Packagist | mediawiki/core | ≥ 1.33.0&&< 1.33.1 | 1.33.1composer require mediawiki/core:^1.33.1 |
Affected Products
debian linuxdebianfedorafedoraprojectmediawikimediawikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/core to 1.31.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16738 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2019-16738 in your dependencies?
Find it across Packagist, including transitive dependencies.