NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-12935 — shopware

MEDIUM

CVE-2019-12935 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in shopware/shopware. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for shopware/shopware — see the affected versions and patch details below.

Shopware Cross-site Scripting Vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
2.23%2.89%3.55%4.21%3.7%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘shopware/shopware

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Shopware before 5.5.8 has XSS via the Query String to the backend/Login or backend/Login/load/ URI.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistshopware/shopwareall versions5.5.8composer require shopware/shopware:^5.5.8

Affected Products

1 product · 1 configurations
Application
shopwareshopware
< 5.5.8
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shopware/shopware, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update shopware/shopware to 5.5.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12935 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2019-12935

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2019-12935 -u https://target
Template
Shopware < 5.5.8 - Cross-Site Scripting
Severity
high
Impact
Attackers can execute malicious scripts in the victim's browser, potentially leading to session hijacking or defacement.
Remediation
Update to version 5.5.8 or later.

Template by ProjectDiscovery nuclei-templates (pussycat0x), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Shopware before 5.5.8 has XSS via the Query String to the backend/Login or backend/Login/load/ URI.
O3 Security · Impact-Aware SCA

Is CVE-2019-12935 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-12935: shopware XSS — Fixed in 5.5.8