CVE-2019-12468 — core
CRITICALCVE-2019-12468 is a critical-severity (CVSS 9.8) Missing Authentication vulnerability in mediawiki/core. A fix is available for mediawiki/core — see the affected versions and patch details below.
Wikimedia MediaWiki Incorrect Access Control vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mediawiki/core🐘mediawiki/core🐘mediawiki/core🐘mediawiki/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1. Directly POSTing to Special:ChangeEmail would allow for bypassing re-authentication, allowing for potential account takeover.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mediawiki/core | ≥ 1.27.0&&< 1.27.6 | 1.27.6composer require mediawiki/core:^1.27.6 |
| 🐘Packagist | mediawiki/core | ≥ 1.30.0&&< 1.30.2 | 1.30.2composer require mediawiki/core:^1.30.2 |
| 🐘Packagist | mediawiki/core | ≥ 1.31.0&&< 1.31.2 | 1.31.2composer require mediawiki/core:^1.31.2 |
| 🐘Packagist | mediawiki/core | ≥ 1.32.0&&< 1.32.2 | 1.32.2composer require mediawiki/core:^1.32.2 |
Affected Products
debian linuxdebianmediawikimediawikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mediawiki/core to 1.27.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12468 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2019-12468 in your dependencies?
Find it across Packagist, including transitive dependencies.