NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-12139 — ezplatform-admin-ui

MEDIUM

CVE-2019-12139 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ezsystems/ezplatform-admin-ui. A fix is available for ezsystems/ezplatform-admin-ui — see the affected versions and patch details below.

ezplatform-admin-ui Cross-site Scripting (XSS) vulnerability

Also known asGHSA-99rh-vxmc-7wgf
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.35%0.3%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘ezsystems/ezplatform-admin-ui🐘ezsystems/ezplatform-admin-ui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An XSS issue was discovered in the Admin UI in eZ Platform 2.x. This affects ezplatform-admin-ui 1.3.x before 1.3.5 and 1.4.x before 1.4.4, and ezplatform-page-builder 1.1.x before 1.1.5 and 1.2.x before 1.2.4.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistezsystems/ezplatform-admin-ui≥ 1.3&&< 1.3.51.3.5composer require ezsystems/ezplatform-admin-ui:^1.3.5
🐘Packagistezsystems/ezplatform-admin-ui≥ 1.4&&< 1.4.41.4.4composer require ezsystems/ezplatform-admin-ui:^1.4.4

Affected Products

2 products · 4 configurations
Application
ezplatform-admin-uiez
≥ 1.4.0 && < 1.4.4
range
Application
ezplatform-page-builderez
≥ 1.2.0 && < 1.2.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezplatform-admin-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ezsystems/ezplatform-admin-ui to 1.3.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12139 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An XSS issue was discovered in the Admin UI in eZ Platform 2.x. This affects ezplatform-admin-ui 1.3.x before 1.3.5 and 1.4.x before 1.4.4, and ezplatform-page-builder 1.1.x before 1.1.5 and 1.2.x before 1.2.4.
O3 Security · Impact-Aware SCA

Is CVE-2019-12139 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-12139: ezplatform-admin-ui XSS — Fixed in 1.3.5