ezplatform-admin-ui Cross-site Scripting (XSS) vulnerabilityGHSA-99rh-vxmc-7wgf
MEDIUMGHSA-99rh-vxmc-7wgf is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ezsystems/ezplatform-admin-ui. A fix is available for ezsystems/ezplatform-admin-ui — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ezsystems/ezplatform-admin-ui🐘ezsystems/ezplatform-admin-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An XSS issue was discovered in the Admin UI in eZ Platform 2.x. This affects ezplatform-admin-ui 1.3.x before 1.3.5 and 1.4.x before 1.4.4, and ezplatform-page-builder 1.1.x before 1.1.5 and 1.2.x before 1.2.4.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | ezsystems/ezplatform-admin-ui | ≥ 1.3&&< 1.3.5 | 1.3.5composer require ezsystems/ezplatform-admin-ui:^1.3.5 |
| 🐘Packagist | ezsystems/ezplatform-admin-ui | ≥ 1.4&&< 1.4.4 | 1.4.4composer require ezsystems/ezplatform-admin-ui:^1.4.4 |
Affected Products
ezplatform-admin-uiezezplatform-page-builderezDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezplatform-admin-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ezsystems/ezplatform-admin-ui to 1.3.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-99rh-vxmc-7wgf is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-99rh-vxmc-7wgf in your dependencies?
Find it across Packagist, including transitive dependencies.