NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

ezplatform-admin-ui vulnerable to Cross-Site Scripting (XSS)GHSA-58h5-h554-429q

Fix: ezsystems/ezplatform-admin-ui@29e156a

GHSA-58h5-h554-429q is a security vulnerability in ezsystems/ezplatform-admin-ui. A fix is available for ezsystems/ezplatform-admin-ui — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Dec 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐘ezsystems/ezplatform-admin-ui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

It is possible to inject JavaScript XSS in the content type entries "name" and "short name". To exploit this, one must already have permission to edit content types, which limits it in many cases to people who are already administrators. However, please verify which users have this permission. The fix ensures any injections are escaped.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistezsystems/ezplatform-admin-ui≥ 2.3.0&&< 2.3.262.3.26composer require ezsystems/ezplatform-admin-ui:^2.3.26

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezplatform-admin-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ezsystems/ezplatform-admin-ui to 2.3.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-58h5-h554-429q is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

It is possible to inject JavaScript XSS in the content type entries "name" and "short name". To exploit this, one must already have permission to edit content types, which limits it in many cases to people who are already administrators. However, please verify which users have this permission. The fix ensures any injections are escaped.
O3 Security · Impact-Aware SCA

Is GHSA-58h5-h554-429q in your dependencies?

Find it across Packagist, including transitive dependencies.

ezplatform-admin-ui vulnerable to Cross-Site Scripting…