NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Improper Certificate Validation in node-sass affects eZ PlatformGHSA-6v6p-g8cg-2hgg

MEDIUM

GHSA-6v6p-g8cg-2hgg is a medium-severity (CVSS 5.3) vulnerability in ezsystems/ezplatform-admin-ui. A fix is available for ezsystems/ezplatform-admin-ui — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Dec 5, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐘ezsystems/ezplatform-admin-ui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path. This affects eZ Platform v2.5 only. The maintainers resolved it by replacing node-sass 4.11 with sass 1.32.13. This issue also affects ezsystems/ezplatform and ezsystems/ezplatform-page-builder.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistezsystems/ezplatform-admin-ui≥ 1.5.0&&< 1.5.271.5.27composer require ezsystems/ezplatform-admin-ui:^1.5.27

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezplatform-admin-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ezsystems/ezplatform-admin-ui to 1.5.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6v6p-g8cg-2hgg is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path. This affects eZ Platform v2.5 only. The maintainers resolved it by replacing node-sass 4.11 with sass 1.32.13. This issue also affects ezsystems/ezplatform and ezsystems/ezplatform-page-builder.
O3 Security · Impact-Aware SCA

Is GHSA-6v6p-g8cg-2hgg in your dependencies?

Find it across Packagist, including transitive dependencies.

Improper Certificate Validation in node-sass affects eZ…