NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

eZ Platform Admin UI vulnerable to DOM-based Cross-site Scripting in file upload widgetGHSA-gc5h-6jx9-q2qh

MEDIUMFix: ezsystems/ezplatform-admin-ui@7a9f991

GHSA-gc5h-6jx9-q2qh is a medium-severity (CVSS 5.4) vulnerability in ezsystems/ezplatform-admin-ui. A fix is available for ezsystems/ezplatform-admin-ui — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Feb 4, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐘ezsystems/ezplatform-admin-ui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The file upload widget is vulnerable to XSS payloads in filenames. Access permission to upload files is required. As such, in most cases only authenticated editors and administrators will have the required permission. It is not persistent, i.e. the payload is only executed during the upload. In effect, an attacker will have to trick an editor/administrator into uploading a strangely named file. The fix ensures XSS is escaped.

Patches

See "Patched versions". Commit: https://github.com/ezsystems/ezplatform-admin-ui/commit/7a9f991b200fa5a03d49cd07f50577c8bc90a30b

Workarounds

None.

References

Credit

This vulnerability was discovered and reported to Ibexa by Alec Romano: https://github.com/4rdr We thank them for reporting it responsibly to us.

How to report security issues: https://doc.ibexa.co/en/latest/infrastructure_and_maintenance/security/reporting_issues/

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistezsystems/ezplatform-admin-ui≥ 3.3.0&&< 3.3.393.3.39composer require ezsystems/ezplatform-admin-ui:^3.3.39

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezplatform-admin-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ezsystems/ezplatform-admin-ui to 3.3.39 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gc5h-6jx9-q2qh is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact The file upload widget is vulnerable to XSS payloads in filenames. Access permission to upload files is required. As such, in most cases only authenticated editors and administrators will have the required permission. It is not persistent, i.e. the payload is only executed during the upload. In effect, an attacker will have to trick an editor/administrator into uploading a strangely named file. The fix ensures XSS is escaped. ### Patches See "Patched versions". Commit: https://github.com/ezsystems/ezplatform-admin-ui/commit/7a9f991b200fa5a03d49cd07f50577c8bc90a30b ### Workarounds
O3 Security · Impact-Aware SCA

Is GHSA-gc5h-6jx9-q2qh in your dependencies?

Find it across Packagist, including transitive dependencies.

eZ Platform Admin UI vulnerable to DOM-based…