NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven📦 npm.NET NuGet🐘 Packagist🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2019-11358 — jquery

MEDIUMFix: jquery/jquery@753d591

CVE-2019-11358 is a medium-severity (CVSS 6.1) CWE-1321 vulnerability in org.webjars.npm:jquery. 16 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.webjars.npm:jquery — see the affected versions and patch details below.

XSS in jQuery as used in Drupal, Backdrop CMS, and other products

Also known asDRUPAL-CORE-2019-006GHSA-6c3j-c64m-qhgqPYSEC-2026-628SNYK-JS-JQUERY-174006
Published
Updated
Affected
7 pkgs
Patched
7 / 7
Exploits
16 known
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2019-11358.

EPSS Exploitation Probability

via FIRST.org ↗
86.8%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%2.7%86.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

7 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

22Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
jquerynpm
11.7Mdownloads / week

Description

jQuery from 1.1.4 until 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype.

Affected Packages

7 total 7 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.webjars.npm:jquery≥ 1.1.4&&< 3.4.03.4.0org.webjars.npm:jquery:3.4.0
📦npmjquery≥ 1.1.4&&< 3.4.03.4.0npm install jquery@3.4.0
.NETNuGetjQuery≥ 1.1.4&&< 3.4.03.4.0dotnet add package jQuery --version 3.4.0
🐘Packagistmaximebf/debugbarall versions1.19.0composer require maximebf/debugbar:^1.19.0
🐍PyPIdjango≥ 2.0a1&&< 2.1.92.1.9pip install --upgrade 'django==2.1.9'
🐍PyPIdjango≥ 2.2a1&&< 2.2.22.2.2pip install --upgrade 'django==2.2.2'

Affected Products

105 products · 218 configurations
Application
backdropbackdropcms
≥ 1.12.0 && < 1.12.6
range
OS
debian linuxdebian
3 versions
8.09.010.0
Application
drupaldrupal
≥ 8.6.0 && < 8.6.15
range
OS
fedorafedoraproject
3 versions
282930
Application
joomla\!joomla
≥ 3.0.0 && ≤ 3.9.4
range
Application
jqueryjquery
< 3.4.0
range
Exploits & PoCs
16

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-52141webappsmultiple

jQuery 3.3.1 - Prototype Pollution & XSS Exploit

by xOryus · Apr 8, 2025

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:jquery, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.webjars.npm:jquery to 3.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-11358 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat Virtualization 4.2 EUS contains the affected version of bootstrap in the packages ovirt-js-dependencies and ovirt-engine-dashboard. These packages are deprecated in Red Hat Virtualization 4.3.

ProductFixed inAdvisory
CloudForms Management Engine 5.10ansible-tower-0:3.5.2-1.el7atRHSA-2019:2587
Red Hat Enterprise Linux 7ipa-0:4.6.8-5.el7RHSA-2020:3936
Red Hat Enterprise Linux 7pcs-0:0.9.169-3.el7_9.3RHSA-2022:7343
Red Hat Enterprise Linux 8idm:client-8030020200923172426.05ac3f11RHSA-2020:4670
Red Hat Enterprise Linux 8pki-core:10.6-8030020200911215836.5ff1562fRHSA-2020:4847
Red Hat Enterprise Linux 8pcs-0:0.10.10-4.el8RHSA-2021:4142
Red Hat JBoss Enterprise Application Platform 7.4.9org.jboss.hal/hal-console:3.3.16.Final-redhat-00001RHSA-2023:0556
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el8eapRHSA-2023:0553
UbuntuMEDIUM

Frequently Asked Questions

jQuery from 1.1.4 until 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles `jQuery.extend(true, {}, ...)` because of `Object.prototype` pollution. If an unsanitized source object contained an enumerable `__proto__` property, it could extend the native `Object.prototype`.
O3 Security · Impact-Aware SCA

Is CVE-2019-11358 in your dependencies?

Find it across Maven, npm, NuGet, including transitive dependencies.

CVE-2019-11358: jquery — Fixed in 3.4.0