XSS in jQuery as used in Drupal, Backdrop CMS, and other productsGHSA-6c3j-c64m-qhgq
MEDIUMFix: jquery/jquery#4333GHSA-6c3j-c64m-qhgq is a medium-severity (CVSS 6.1) CWE-1321 vulnerability in org.webjars.npm:jquery. 16 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.webjars.npm:jquery — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-6c3j-c64m-qhgq.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
jquerynpmDescription
jQuery from 1.1.4 until 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.webjars.npm:jquery | ≥ 1.1.4&&< 3.4.0 | 3.4.0org.webjars.npm:jquery:3.4.0 |
| 📦npm | jquery | ≥ 1.1.4&&< 3.4.0 | 3.4.0npm install jquery@3.4.0 |
| .NETNuGet | jQuery | ≥ 1.1.4&&< 3.4.0 | 3.4.0dotnet add package jQuery --version 3.4.0 |
| 🐘Packagist | maximebf/debugbar | all versions | 1.19.0composer require maximebf/debugbar:^1.19.0 |
| 🐍PyPI | django | ≥ 2.0a1&&< 2.1.9 | 2.1.9pip install --upgrade 'django==2.1.9' |
| 🐍PyPI | django | ≥ 2.2a1&&< 2.2.2 | 2.2.2pip install --upgrade 'django==2.2.2' |
Affected Products
backdropbackdropcmsdebian linuxdebiandrupaldrupalfedorafedoraprojectjoomla\!joomlajqueryjqueryResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
jQuery 3.3.1 - Prototype Pollution & XSS Exploit
by xOryus · Apr 8, 2025
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:jquery, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.webjars.npm:jquery to 3.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6c3j-c64m-qhgq is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Virtualization 4.2 EUS contains the affected version of bootstrap in the packages ovirt-js-dependencies and ovirt-engine-dashboard. These packages are deprecated in Red Hat Virtualization 4.3.
| Product | Fixed in | Advisory |
|---|---|---|
| CloudForms Management Engine 5.10 | ansible-tower-0:3.5.2-1.el7at | RHSA-2019:2587 |
| Red Hat Enterprise Linux 7 | ipa-0:4.6.8-5.el7 | RHSA-2020:3936 |
| Red Hat Enterprise Linux 7 | pcs-0:0.9.169-3.el7_9.3 | RHSA-2022:7343 |
| Red Hat Enterprise Linux 8 | idm:client-8030020200923172426.05ac3f11 | RHSA-2020:4670 |
| Red Hat Enterprise Linux 8 | pki-core:10.6-8030020200911215836.5ff1562f | RHSA-2020:4847 |
| Red Hat Enterprise Linux 8 | pcs-0:0.10.10-4.el8 | RHSA-2021:4142 |
| Red Hat JBoss Enterprise Application Platform 7.4.9 | org.jboss.hal/hal-console:3.3.16.Final-redhat-00001 | RHSA-2023:0556 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8 | eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el8eap | RHSA-2023:0553 |
Frequently Asked Questions
Is GHSA-6c3j-c64m-qhgq in your dependencies?
Find it across Maven, npm, NuGet, including transitive dependencies.