CVE-2012-6708 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars.npm:jquery. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.webjars.npm:jquery — see the affected versions and patch details below.
Cross-Site Scripting in jquery
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
jquerynpmDescription
jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the '<' character anywhere in the string, giving attackers more flexibility when attempting to construct a malicious payload. In fixed versions, jQuery only deems the input to be HTML if it explicitly starts with the '<' character, limiting exploitability only to attackers who can control the beginning of a string, which is far less common.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.webjars.npm:jquery | all versions | 1.9.0org.webjars.npm:jquery:1.9.0 |
| 📦npm | jquery | all versions | 1.9.0npm install jquery@1.9.0 |
| .NETNuGet | jQuery | all versions | 1.9.0dotnet add package jQuery --version 1.9.0 |
| 💎RubyGems | jquery-rails | all versions | 2.2.0bundle update jquery-rails --conservative |
Affected Products
jqueryjqueryResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Linksys EA7500 2.0.8.194281 - Cross-Site Scripting
by MiningOmerta · Mar 25, 2021
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:jquery, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.webjars.npm:jquery to 1.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-6708 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Frequently Asked Questions
Is CVE-2012-6708 in your dependencies?
Find it across Maven, npm, NuGet, including transitive dependencies.